FontLab

From Digi Wiki
Jump to: navigation, search

Overview

FontLab Studio 5 is our next-generation professional font editor. It is the comprehensive solution for font foundries, professional type designers, typographers and graphic design studios, allowing them to design typefaces and create or modify fonts.

Macintosh HD > Applications > FontLab Studio > FontLab Studio or the icon in the dock. - fig.1

fig.1

Creating Your Font

1) Scan in images or sketches that you are using for characters.

2) Open the scans in Adobe Photoshop.

3) Change levels to make all characters black and erase all areas that are not necessary in your alphabet. - fig.2

fig.2

4) Save As PSD. - fig.3

fig.3

5) Open a new document in Adobe Illustrator.

6) File > Place PSD file in new document. - fig.4

fig.4

7) Go to Object > Image Trace > Make & Expand. - fig.5

fig.5

8) Click the background with the Direct Selection Tool.

9) Go to Select > Same > Fill Color and then press Delete. - fig.6

fig.6

10) Object > Ungroup to ungroup the image.

11) For uppercase letters, use the rectangle tool to make a box that is 700x700 pixels. You need to do this so you don’t have to change it once you are in FontLab because it is more difficult to scale. 700 is the standard size of the fonts made in font lab. - fig.7

fig.7

12) For lowercase letters, use the rectangle tool to make a box that is 300x300 pixels. Resize lowercase letters to be 300 pixels tall (some letter: t l i f h j k may be larger than 300).

13) Open a new project in FontLab.

14) Copy your first character in Illustrator. - fig.10

fig.10

15) Double Click the coinciding letter in FontLab. - fig.11

fig.11

16) Paste character into the new window. - fig.12

fig.12

17) Align to bottom left. Note: Some letters are formatted to hang below line. - fig.13

fig.13

18) Continue with remaining letters.

19) File > Save As

20) To set up Information for Font, go to File > Font Info. - fig.14

fig.14

21) Now that the font is complete, it needs to be generated. - fig.15

fig.15

22) File > Generate All.

23) File type should be TrueType/Open Type TT (.ttf).

24) Push Start.

25) To begin using font, open Extensis Suticase.

26) Click the folder that says New Set. - fig.16

fig.16

27) Drag your font off of the Desktop into the newly created set folder.

28) Activate your font. - fig.17

fig.17