After Effects

From Digi Wiki
Jump to: navigation, search

Overview

Adobe After Effects is a digital motion graphics and compositing software. Its main purpose is for film and video post-production. After Effects uses a system of layers organized on a timeline to create composites from still images and motion footage, such as video files. Properties such as position and opacity can be controlled independently for each layer, and each layer can have effects applied. After Effects is often described as the "Photoshop of video," because its flexibility allows compositors to alter video in any way they see fit, as Photoshop does for images.

The After Effects file on lab computers can be found at Macintosh HD > Applications > Adobe After Effects CS6 Folder > Adobe After Effects CS6 or by clicking the icon in the dock. - fig.1

fig.1

Supported Import Formats in After Effects

Audio formats

Advanced Audio Coding (AAC, M4A)

Audio Interchange File Format (AIF, AIFF)

MP3 (MP3, MPEG, MPG, MPA, MPE)

Video for Windows (AVI, WAV; requires QuickTime on Mac OS)

Waveform (WAV)

Still-image formats

Adobe Illustrator (AI, AI4, AI5, EPS, PS; continuously rasterized)

Adobe PDF (PDF; first page only; continuously rasterized)

Adobe Photoshop (PSD)

Bitmap (BMP, RLE, DIB)

Camera raw (TIF, CRW, NEF, RAF, ORF, MRW, DCR, MOS, RAW, PEF, SRF, DNG, X3F, CR2, ERF; 16 bpc)

Cineon (CIN, DPX; converts to project’s color bit depth: 8, 16, or 32 bpc)

Discreet RLA/RPF (RLA, RPF; 16 bpc, imports camera data)

EPS

JPEG (JPG, JPE)

Maya camera data (MA)

Maya IFF (IFF, TDI; 16 bpc)

OpenEXR (EXR; 32 bpc)

PBM (8, 16, and 32 bpc)

PCX

PICT (PCT)

Pixar (PXR)

Portable Network Graphics (PNG; 16 bpc)

Radiance (HDR, RGBE, XYZE; 32 bpc)

SGI (SGI, BW, RGB; 16 bpc)

Softimage (PIC)

Targa (TGA, VDA, ICB, VST)

TIFF (TIF)

Video and animation formats

Animated GIF (GIF)

DV (in MOV or AVI container, or as containerless DV stream)

ElectricImage (IMG, EI)

Filmstrip (FLM)

Flash (SWF; continuously rasterized)

MPEG formats (MPEG, MPE, MPG, M2V, MPA, MP2, M2A, MPV, M2P, M2T, VOB, MOD, AC3, MP4, M4V, M4A)

Open Media Framework (OMF; raw media [or essence] only; Windows only)

QuickTime (MOV; 16 bpc, requires QuickTime)

Adobe Photoshop with video layer (PSD; requires QuickTime)

Video for Windows (AVI, WAV; requires QuickTime on Mac OS)

Windows Media File (WMV, WMA, ASF; Windows only)

Project formats

Advanced Authoring Format (AAF; Windows only)

Adobe Premiere 6.0 and 6.5 (PPJ)

Adobe Premiere Pro 1.0, 1.5, 2.0, CS3 (PRPROJ; 1.0, 1.5, and 2.0 Windows only)

Adobe After Effects 4.0 and later (AEP, AET)

XML Forms Data Format (XFDF; for importing of Clip Notes comments)

After Effects Tool Bar (Quick Key)

fig. 1



1) Selection (V)

2) Hand (H)

3) Zoom (Z)

4) Rotation (W)

5) Unified Camera (C)

6) Pan Behind (Y)

7) Rectangle (Q)

8) Pen tools (G)

9) Horizontal Type (Cmd+T)

10) Brush (Cmd+B)

11) Clone Stamp (Cmd+B)

12) Eraser (Cmd+B)

13) Roto Brush (Option+W)

14) Puppet Pin (Cmd+P)

15) Axis Modes

Opening a New Project

1) To start a new project in After Effects simply press Command N or go to File > New > New Project.

2) After you open a new composition, a dialogue box will appear in which you will select your preferred settings. - fig.2

fig.2



Importing Footage

1) After you have opened a new composition (command+n) you can begin importing footage for your project.

2) There are two ways to import footage in an After Effects composition.

  • Click File > Import and then select the option that describes what you are importing. For example if you are importing many different elements select Multiple Files but if you are importing just one thing, choose File. - fig.3


fig.3



  • The other option is to right click in the Project Panel on the left hand side and select Import and choose your preferred import method. - fig.4


fig.4


3) After you select your import method, you will have to locate your file. If you are importing multiple files for a stop motion, you should select Jpeg Sequence.


fig.5


4) In order to place the file you imported into your stage you have two options.


  • The first is to drag your import into the timeline. - fig.6


fig.6



  • The second is to drag your import directly on to the stage. - fig.7



fig.7




Creating and Managing Layers

  • Once you have imported files you can drag and drop your files into the "Project Panel". Dragging these layers into the Project Panel will create layers within your composition.
    • Organize these layers with visibility in mind. The first layer in the panel will be the top layer and the last will the bottom. If the first layer is a solid color filling the composition, you will not be able to see any of your elements. Note in Fig. 8 how in the Project Panel the mint green square's layer is below Kanye, therefore it is behind the image of Kanye in the composition.


fig 8

Creating Parent Objects to Manage Multiple Layers

  • If you want multiple items to do the same thing, you can easily do this by creating assigning these layers a parent. Once you assign an object a parent it will automatically follow the instructions that you give to the parent. A lot of times it is beneficial to create a "null object" as your parent, rather than one of your active layers. A null object is a layer without value or consequence that you can use to set as a marker or a guide in your composition, but will not effect your final project.
    • When parenting multiple layers, first create a null object by right clicking in the Project Panel and selecting New> Null Object.
fig 9


    • Next go to the "Parent" tab in the Project Panel and select your null object. If it is your first null object it will be by default called "Null 1"
fig 10


  • Now edit your parent layer and simultaneously edit all of its "children" layers.



Animating Text

After Effects has pretty solid text editing capabilities. These are some ways you can manipulate text in After Effects.

  • Select the Type tool in the upper left hand of the tool bar.
fig 11
  • Place the text tool in the desired area of your composition and click and type.
fig 12
  • You can easily edit the text by using the "Characters" menu that is nested on the right hand side of the screen.
fig 13


  • Once you have added text to your composition, you can animate and apply effects to the text. For animation options and effects locate your text layer in the Projects Panel and expand the menu. Within the menu you will see the options "Text" and "Transform".
fig 14


  • To animate the text expand the Animate option. Then choose the effect that you would like to apply to the text.
fig 15


  • A simple demonstration of using the Animate option can be shown through the "Position" option. When you select "Position" or any other item in the Animate menu your layer will expand inside the Timeline.
fig 16


fig 17


  • Place the text where you would like it to start off and hit the stopwatch next to Position. A diamond will on the timeline, this diamond is called a "keyframe". Keyframes mark start and end points within your timeline. Sliding keyframes on the timeline is an easy way to edit the amount of time your animation will take. You can also easily add and delete keyframes.
fig 18


  • After your stopwatch is activated move the slider to a further point in the timeline. Next you can move the text to where you want it to be at that time. You can also edit the text's position by adjusting the numerical position of the text next to Position. This numerical slider looks like (###.#,###.#) and represents the x and y axises. You can either scrub on the time line or go to the beginning of the timeline and press to space bar to preview your changes.
fig 19

Simple Transitions

  • Open a new or pre-existing composition. Import the files that you wish to create a transition between. Drag your files into the timeline. Organize your files based on time. Place the layer that you wish to begin the transition first in the timeline and the layer you are transitioning to below it.
  • Select your first layer and go to the "Effects and Presets" menu on the right and expand the "Transition" tab. Double click your desired transition.
fig 20
  • After double clicking your desired transition, a transition menu will appear in the upper left corner of the program. You can edit your Transition here or in the timeline under your first layer>Effects>(Your Transition)
fig 21


fig 22


  • While in the Effects menu, select where on the time line you want the pre-transition footage to begin its transition and press the small stop watch right next to the value option called "Transition Completion" making sure its value is at 0%.
fig 23


  • Move the cursor on the Timeline to where you what the transition to be complete. Then change the "Completion" setting to 100%.
fig 24

Keyframing

Key frames are points within a composition that indicate the beginning or end of an action within a layer. You can use keyframe to synchronize and organize the elements within a project.

  • You can use keyframes to edit and control any type of layer whether it is a vector, photograph, text, etc. As an example this tutorial will be using text.
  • Select the Text tool in your toolbox and type some sample text.
  • After that go ahead and reposition your text with the selection tool until it’s in the center.
fig 25
  • Click the drop arrow beside your text on the timeline

You should get two drop downs one labeled Text and the other labeled Transform

  • Click the arrow beside transform

This should expose your key frame options Anchor Point, Position, Scale, Rotation, and Opacity

  • Activate all of the stopwatches next to the keyframe options
fig 26


Anchor Point

  • Select the Anchor Point layer
  • Drag the timeline arrow to the right to allow for time to pass before the action begins.
  • Change the anchor point coordinates
  • A new keyframe box should popup in the timeline - you've just made a keyframe!


fig 27
fig 28


Position

Position changes the position of your text, obviously. To change your position simply click and drag your text to a different location.

  • Drag the yellow time line indicator to the time that you want your text to finish moving.
  • Grab text with the selection tool
  • Place it in a new position on the screen
fig 29


Scale

How increase or decrease the size of the object you’re working with can be editing with the scale feature.

  • Drag the yellow arrow at the top of your timeline to allow for time to pass before the action begins
  • Click the corner of your object and drag in to make it smaller or out to make it larger (hold shift while dragging to maintain proportion) or scrub the percentage next to the Scale feature to more accurately change the size of the object.
fig 30


Rotation

Rotation is changing the position of your object from its original anchor point

  • Drag the yellow arrow at the top of your timeline to allow for time to pass before the action begins
  • Select your rotation tool
  • Move text manually, or by scrubbing the rotation values.


fig 31


Opacity

Opacity is fading in and out basically, transparency.

  • Drag the yellow arrow at the top of your timeline to allow for time to pass before the action begins
  • input a different value other than 100%


fig 32

Sound Troubleshooting

Previewing Sound

If you are unable to hear sound when previewing your file, go to Preferences to change the output mapping to Built-In Line Output.


fig. 33


fig. 34

Exporting

Render and export a movie using the render queue

  • When you are ready to export your AE file go to Composition>Add to Render Queue.
fig 34
  • Double click on the "Output To" option and specify the file name, type and where you want it to be saved.
fig 35
  • Double click "Best Settings" next to Render Settings to custom edit your save. Here you can edit things like resolution and frame rate.
fig 36


  • Double click "Output Module." You use the output module settings to specify the file format of the output movie. In some cases, a format-specific dialog box opens after you choose a format, in which you can specify format-specific settings.
fig 37

6. Click the Render button in the upper-right corner of the Render Queue panel.

fig 38

Exporting Audio

To export Audio in After effects:

  • First add your composition to the render queue


Step 1


  • Next select the option Output Module


Step 2


  • Check the box that says Audio Output


Step 3


  • This step is vital to exporting a video with audio.

Edit audio as you wish!




Supported Output Formats

Video and animation formats

3GPP (3GP, 3G2, AMC; requires QuickTime 6.5 or later)

Adobe Clip Notes (PDF containing rendered movie)

Animated GIF (GIF)


Cineon (CIN, DPX; 16 and 32 bpc converted to 10 bpc)

ElectricImage (IMG, EIZ)

Filmstrip (FLM)

Flash (SWF)

Flash Video (FLV)

H.264 and H.264 Blu-ray

MPEG-2 (Windows and Mac OS on Intel-based Mac only)

MPEG-2 DVD (Windows and Mac OS on Intel-based Mac only)

MPEG-2 Blu-ray (Windows and Mac OS on Intel-based Mac only)

MPEG-4

OMF (media [essence] only, Windows only)

QuickTime (MOV, DV; requires QuickTime for 8 bpc and codec support for 16 bpc)

RealMedia (RAM, RM; Windows only)

Video for Windows (AVI)

Windows Media (Windows only)

Still-image formats

Adobe Photoshop (PSD; 8, 16, and 32 bpc)

Bitmap (BMP, RLE)

CompuServe GIF (GIF)

Maya IFF (IFF; 16 bpc)

JPEG (JPG, JPE)

Open EXR (EXR)

Pict (PCT, PIC)

PNG (PNG; 16 bpc)

Radiance (HDR, RGBE, XYZE)

RLE (RLE)

SGI (SGI, BW, RGB, 16 bpc)

Targa (TGA, VBA, ICB, VST)

TIFF (TIF; 8, 16, and 32 bpc)

Audio-only formats

AU audio file (AU)

Audio Interchange File Format (AIFF)

MP3 (MP3)

WAV

Relevant Links

http://www.adobe.com/designcenter/video_workshop/